set -e; lockfile=/usr/tmp/pkgsrc/audio/nas/work/.lockfile; locktype=sleep; [ "audio/nas" != "pkgtools/shlock" ] || exit 0; [ -x /usr/bin/shlock"" ] || { echo 1>&2 "ERROR:" "[locking.mk] shlock is not installed."; echo 1>&2 "ERROR:" "[locking.mk] Please \"(cd ../../pkgtools/shlock && /usr/bin/make install)\"."; exit 1; }; ppid=`/bin/ps -p $$ -o ppid | /usr/bin/awk 'NR == 2 { print $1 }'`; if [ -z "$ppid" ]; then echo 1>&2 "ERROR:" "No parent process ID found."; exit 1; fi; while :; do if [ -f /var/run/dmesg.boot -a -f "$lockfile" ]; then rebooted=`/usr/bin/find /var/run/dmesg.boot -newer "$lockfile" -print`; if [ "$rebooted" ]; then echo "=>" "Removing stale $lockfile"; /bin/rm -f "$lockfile"; fi; fi; lockdir=`echo "$lockfile" | sed "s,/[^/]*\$,,"`; /bin/mkdir -p "$lockdir"; if /usr/bin/shlock -f "$lockfile" -p "$ppid"; then break; fi; lockpid=`/bin/cat "$lockfile"`; case "$locktype" in once) /bin/sh /usr/pkgsrc/mk/scripts/fail echo 1>&2 "ERROR:" "Lock acquire-bootstrap-depends-lock is held by pid $lockpid" ;; sleep) echo "=>" "Lock acquire-bootstrap-depends-lock is held by pid $lockpid"; /bin/sleep 5; ;; esac; done; lockpid=`/bin/cat "$lockfile"`; echo "=>" "Lock $lockfile acquired for \`\`bootstrap-depends'' on behalf of process $lockpid"; => Lock /usr/tmp/pkgsrc/audio/nas/work/.lockfile acquired for ``bootstrap-depends'' on behalf of process 22450 set -e;/usr/bin/env AWK=/usr/bin/awk PKG_ADMIN=/usr/sbin/pkg_admin\ -K\ /var/db/pkg PKGSRCDIR=/usr/pkgsrc PWD_CMD=/bin/pwd SED=/usr/bin/sed /bin/sh /usr/pkgsrc/mk/pkgformat/pkg/list-dependencies " "\ \ digest\>=20010302:../../pkgtools/digest " " " " " " | while read type pattern dir; do test "$type" = "bootstrap" || continue; case $type in bootstrap) Type=Bootstrap;; tool) Type=Tool;; build) Type=Build;; full) Type=Full;; esac; case $type in bootstrap|tool) if expr "NO" : '[yY][eE][sS]' >/dev/null; then extradep=""; else extradep=" nas-1.9.3"; fi; cross=no; archopt=TARGET_ARCH=x86_64; pkg=`/usr/sbin/pkg_info -K /var/db/pkg -E "$pattern" || true`; ;; build|full) extradep=" nas-1.9.3"; cross=NO; archopt=; pkg=`/usr/sbin/pkg_info -K /var/db/pkg -E "$pattern" || true`; ;; esac; case "$pkg" in "") echo "=>" "$Type dependency $pattern: NOT found"; target=package-install; echo "=>" "Verifying $target for $dir"; [ -d "$dir" ] || /bin/sh /usr/pkgsrc/mk/scripts/fail echo 1>&2 "ERROR:" "[depends.mk] The directory \`\`$dir'' does not exist."; cd $dir; /usr/bin/env MAKECONF=/etc/mk.conf PATH=/usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin:/usr/tmp/pkgsrc/audio/nas/work/.buildlink/bin:/usr/tmp/pkgsrc/audio/nas/work/.gcc/bin:/usr/tmp/pkgsrc/audio/nas/work/.tools/bin:/usr/pkg/bin:/home/ryo_on/bin:/sbin:/bin:/usr/sbin:/opt/bin:/usr/bin:/usr/games:/usr/pkg/sbin:/usr/pkg/bin:/usr/local/bin:/usr/X11R7/bin USE_DESTDIR=yes _PKGSRC_DEPS="$extradep" PKGNAME_REQD="$pattern" USE_CROSS_COMPILE=$cross $archopt /usr/bin/make _MAKE=/usr/bin/make OPSYS=NetBSD OS_VERSION=6.99.21 LOWER_OPSYS=netbsd _PKGSRCDIR=/usr/pkgsrc PKGTOOLS_VERSION=20130131 _CC=/usr/bin/gcc _PATH_ORIG=/home/ryo_on/bin:/sbin:/bin:/usr/sbin:/opt/bin:/usr/bin:/usr/games:/usr/pkg/sbin:/usr/pkg/bin:/usr/local/bin:/usr/X11R7/bin _AUTOMATIC=yes $target; case $type in bootstrap|tool) pkg=`/usr/sbin/pkg_info -K /var/db/pkg -E "$pattern" || true`;; build|full) pkg=`/usr/sbin/pkg_info -K /var/db/pkg -E "$pattern" || true`;; esac; case "$pkg" in "") echo 1>&2 "ERROR:" "[depends.mk] A package matching \`\`$pattern'' should"; echo 1>&2 "ERROR:" " be installed, but one cannot be found. Perhaps there is a"; echo 1>&2 "ERROR:" " stale work directory for $dir?"; exit 1; esac; echo "=>" "Returning to build of nas-1.9.3"; ;; *) case $type in bootstrap|tool) objfmt=`/usr/sbin/pkg_info -K /var/db/pkg -Q OBJECT_FMT "$pkg"`;; build|full) objfmt=`/usr/sbin/pkg_info -K /var/db/pkg -Q OBJECT_FMT "$pkg"`;; esac; case "$objfmt" in "") echo 1>&2 "WARNING:" "[depends.mk] Unknown object format for installed package $pkg" ;; ELF) ;; *) echo 1>&2 "ERROR:" "[depends.mk] Installed package $pkg has an"; echo 1>&2 "ERROR:" " object format \`\`$objfmt'' which differs from \`\`ELF''. Please"; echo 1>&2 "ERROR:" " update the $pkg package to ELF."; exit 1; ;; esac; silent=; if test -z "${silent}"; then echo "=>" "$Type dependency $pattern: found $pkg"; fi; ;; esac; done => Bootstrap dependency digest>=20010302: found digest-20121220 set -e; lockfile=/usr/tmp/pkgsrc/audio/nas/work/.lockfile; locktype=sleep; lockpid=`/bin/cat "$lockfile"`; echo "=>" "Lock $lockfile released for \`\`bootstrap-depends'' on behalf of process $lockpid"; /bin/rm -f "$lockfile" => Lock /usr/tmp/pkgsrc/audio/nas/work/.lockfile released for ``bootstrap-depends'' on behalf of process 22450 set -e; _PKGVULNDIR=`/usr/sbin/pkg_admin -K /var/db/pkg config-var PKGVULNDIR`; vulnfile=$_PKGVULNDIR/pkg-vulnerabilities; if test ! -f "$vulnfile"; then echo ===\> "Skipping vulnerability checks."; echo 1>&2 "WARNING:" "No $vulnfile file found."; echo 1>&2 "WARNING:" "To fix run: \`/usr/sbin/pkg_admin -K /var/db/pkg fetch-pkg-vulnerabilities'."; exit 0; fi; echo ===\> "Checking for vulnerabilities in nas-1.9.3"; /usr/sbin/pkg_admin -K /var/db/pkg audit-pkg nas-1.9.3 || /bin/sh /usr/pkgsrc/mk/scripts/fail echo 1>&2 "ERROR:" "Define ALLOW_VULNERABLE_PACKAGES in mk.conf or IGNORE_URL in pkg_install.conf(5) if this package is absolutely essential." ===> Skipping vulnerability checks. WARNING: No /var/db/pkg/pkg-vulnerabilities file found. WARNING: To fix run: `/usr/sbin/pkg_admin -K /var/db/pkg fetch-pkg-vulnerabilities'. set -e; set -e; case checksum-phase in *-phase) test ! -f /usr/tmp/pkgsrc/audio/nas/work/.extract_done || exit 0 ;; esac; if cd /usr/distfiles && /usr/bin/env DIGEST=/usr/pkg/bin/digest CAT=/bin/cat ECHO=echo SED=/usr/bin/sed TEST=test /bin/sh /usr/pkgsrc/mk/checksum/checksum /usr/pkgsrc/audio/nas/distinfo nas-1.9.3.src.tar.gz; then true; else echo 1>&2 "ERROR:" "Make sure the Makefile and checksum file (/usr/pkgsrc/audio/nas/distinfo)"; echo 1>&2 "ERROR:" "are up to date. If you want to override this check, type"; echo 1>&2 "ERROR:" "\"/usr/bin/make NO_CHECKSUM=yes [other args]\"."; exit 1; fi ===> Invoking ``all'' after barrier for nas-1.9.3 set -e; if test -n "" && /usr/sbin/pkg_info -K /var/db/pkg -qe nas-1.9.3; then echo ===\> "Skipping installation of already handled package"; else cd /usr/pkgsrc/audio/nas && /usr/bin/env MAKECONF=/etc/mk.conf PATH=/usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin:/usr/tmp/pkgsrc/audio/nas/work/.buildlink/bin:/usr/tmp/pkgsrc/audio/nas/work/.gcc/bin:/usr/tmp/pkgsrc/audio/nas/work/.tools/bin:/usr/pkg/bin:/home/ryo_on/bin:/sbin:/bin:/usr/sbin:/opt/bin:/usr/bin:/usr/games:/usr/pkg/sbin:/usr/pkg/bin:/usr/local/bin:/usr/X11R7/bin USE_DESTDIR=yes /usr/bin/make _MAKE=/usr/bin/make OPSYS=NetBSD OS_VERSION=6.99.21 LOWER_OPSYS=netbsd _PKGSRCDIR=/usr/pkgsrc PKGTOOLS_VERSION=20130131 _CC=/usr/bin/gcc _PATH_ORIG=/home/ryo_on/bin:/sbin:/bin:/usr/sbin:/opt/bin:/usr/bin:/usr/games:/usr/pkg/sbin:/usr/pkg/bin:/usr/local/bin:/usr/X11R7/bin _PKGSRC_BARRIER=yes ALLOW_VULNERABLE_PACKAGES= all || { exitcode="$?"; /usr/bin/env MAKECONF=/etc/mk.conf PATH=/usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin:/usr/tmp/pkgsrc/audio/nas/work/.buildlink/bin:/usr/tmp/pkgsrc/audio/nas/work/.gcc/bin:/usr/tmp/pkgsrc/audio/nas/work/.tools/bin:/usr/pkg/bin:/home/ryo_on/bin:/sbin:/bin:/usr/sbin:/opt/bin:/usr/bin:/usr/games:/usr/pkg/sbin:/usr/pkg/bin:/usr/local/bin:/usr/X11R7/bin USE_DESTDIR=yes /usr/bin/make _MAKE=/usr/bin/make OPSYS=NetBSD OS_VERSION=6.99.21 LOWER_OPSYS=netbsd _PKGSRCDIR=/usr/pkgsrc PKGTOOLS_VERSION=20130131 _CC=/usr/bin/gcc _PATH_ORIG=/home/ryo_on/bin:/sbin:/bin:/usr/sbin:/opt/bin:/usr/bin:/usr/games:/usr/pkg/sbin:/usr/pkg/bin:/usr/local/bin:/usr/X11R7/bin _PKGSRC_BARRIER=yes barrier-error-check; exit "$exitcode"; }; fi set -e; lockfile=/usr/tmp/pkgsrc/audio/nas/work/.lockfile; locktype=sleep; [ "audio/nas" != "pkgtools/shlock" ] || exit 0; [ -x /usr/bin/shlock"" ] || { echo 1>&2 "ERROR:" "[locking.mk] shlock is not installed."; echo 1>&2 "ERROR:" "[locking.mk] Please \"(cd ../../pkgtools/shlock && /usr/bin/make install)\"."; exit 1; }; ppid=`/bin/ps -p $$ -o ppid | /usr/bin/awk 'NR == 2 { print $1 }'`; if [ -z "$ppid" ]; then echo 1>&2 "ERROR:" "No parent process ID found."; exit 1; fi; while :; do if [ -f /var/run/dmesg.boot -a -f "$lockfile" ]; then rebooted=`/usr/bin/find /var/run/dmesg.boot -newer "$lockfile" -print`; if [ "$rebooted" ]; then echo "=>" "Removing stale $lockfile"; /bin/rm -f "$lockfile"; fi; fi; lockdir=`echo "$lockfile" | sed "s,/[^/]*\$,,"`; /bin/mkdir -p "$lockdir"; if /usr/bin/shlock -f "$lockfile" -p "$ppid"; then break; fi; lockpid=`/bin/cat "$lockfile"`; case "$locktype" in once) /bin/sh /usr/pkgsrc/mk/scripts/fail echo 1>&2 "ERROR:" "Lock acquire-configure-lock is held by pid $lockpid" ;; sleep) echo "=>" "Lock acquire-configure-lock is held by pid $lockpid"; /bin/sleep 5; ;; esac; done; lockpid=`/bin/cat "$lockfile"`; echo "=>" "Lock $lockfile acquired for \`\`configure'' on behalf of process $lockpid"; => Lock /usr/tmp/pkgsrc/audio/nas/work/.lockfile acquired for ``configure'' on behalf of process 20683 ===> Configuring for nas-1.9.3 set -e;/bin/rm -f /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILDLINK_PREFIX.kbproto"= "/usr/X11R7 >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILDLINK_PREFIX.libX11"= "/usr/X11R7 >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILDLINK_PREFIX.libXau"= "/usr/X11R7 >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILDLINK_PREFIX.libXdmcp"= "/usr/X11R7 >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILDLINK_PREFIX.libxcb"= "/usr/X11R7 >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILDLINK_PREFIX.oss"= "/usr >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILDLINK_PREFIX.x11-links"= "/usr/pkg >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILDLINK_PREFIX.xcb-proto"= "/usr/X11R7 >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILDLINK_PREFIX.xproto"= "/usr/X11R7 >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILTIN_LIB_FOUND.ossaudio"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILTIN_PKG.libxcb"= "libxcb-1.9.1 >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILTIN_PKG.xcb-proto"= "xcb-proto-1.8 >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILTIN_X11_TYPE.native"= "xorg >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo BUILTIN_X11_VERSION.native"= "7.6 >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo FIND_FILES_libxcb"= "/usr/X11R7/lib/pkgconfig/xcb.pc >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo FIND_FILES_xcb-proto"= "/usr/X11R7/lib/pkgconfig/xcb-proto.pc >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo H_SOUNDCARD"= "/usr/include/soundcard.h >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo H_XAUTH"= "/usr/X11R7/include/X11/Xauth.h >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo H_XDMCP"= "/usr/X11R7/include/X11/Xdmcp.h >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo H_XFUNCPROTO"= "/usr/X11R7/include/X11/Xfuncproto.h >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo H_XKB"= "/usr/X11R7/include/X11/extensions/XKB.h >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo H_XLIB"= "/usr/X11R7/include/X11/Xlib.h >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo IS_BUILTIN.kbproto"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo IS_BUILTIN.libX11"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo IS_BUILTIN.libXau"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo IS_BUILTIN.libXdmcp"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo IS_BUILTIN.libxcb"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo IS_BUILTIN.oss"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo IS_BUILTIN.xcb-proto"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo IS_BUILTIN.xproto"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo TOOLS_PREFIX.digest"= "/usr/pkg >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo TOOLS_PREFIX.gmake"= "/usr/pkg >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo TOOLS_PREFIX.imake"= "/usr/pkg >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo TOOLS_PREFIX.xmkmf"= "/usr/pkg >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo USE_BUILTIN.kbproto"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo USE_BUILTIN.libX11"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo USE_BUILTIN.libXau"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo USE_BUILTIN.libXdmcp"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo USE_BUILTIN.libxcb"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo USE_BUILTIN.oss"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo USE_BUILTIN.x11-links"= "no >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo USE_BUILTIN.xcb-proto"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo USE_BUILTIN.xproto"= "yes >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo _BLNK_PHYSICAL_PATH.LOCALBASE"= "/usr/pkg >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo _BLNK_PHYSICAL_PATH.WRKDIR"= "/usr/tmp/pkgsrc/audio/nas/work >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo _BLNK_PKG_DBDIR.x11-links"= "/var/db/pkg/x11-links-0.79 >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo _IGNORE_INFO_PATH"= " >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo _MANCOMPRESSED"= "no >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo _MANZ"= "no >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo _OSS_TYPE"= "native >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo _USE_TOOLS"= "\[\ awk\ basename\ cat\ chgrp\ chmod\ chown\ cmp\ cp\ cut\ date\ diff\ digest\ dirname\ echo\ egrep\ env\ expr\ false\ file\ find\ ftp\ gmake\ grep\ gzcat\ head\ hostname\ id\ imake\ install\ lex\ ln\ ls\ makedepend\ mkdir\ mv\ patch\ printf\ pwd\ readelf\ rm\ rmdir\ sed\ sh\ shlock\ sleep\ sort\ tail\ tar\ test\ touch\ tr\ true\ uname\ wc\ xargs\ xmkmf\ yacc >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; echo _WRAP_PATH"= "/usr/tmp/pkgsrc/audio/nas/work/.buildlink/bin:/usr/tmp/pkgsrc/audio/nas/work/.gcc/bin:/usr/tmp/pkgsrc/audio/nas/work/.tools/bin:/usr/pkg/bin:/home/ryo_on/bin:/sbin:/bin:/usr/sbin:/opt/bin:/usr/bin:/usr/games:/usr/pkg/sbin:/usr/pkg/bin:/usr/local/bin:/usr/X11R7/bin >> /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp set -e; if test -f /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp; then ( echo ".if !defined(_MAKEVARS_MK)"; echo "_MAKEVARS_MK= defined"; echo ""; /bin/cat /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp; echo ""; echo ".endif # _MAKEVARS_MK"; ) > /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk; /bin/rm -f /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk.tmp; fi set -e;/usr/bin/touch -f /usr/tmp/pkgsrc/audio/nas/work/.configure_makevars.mk cd /usr/tmp/pkgsrc/audio/nas/work/nas-1.9.3/config && /usr/bin/env LIBOSSAUDIO=-lossaudio DEVOSSAUDIO=/dev/audio DEVOSSSOUND=/dev/sound INSTALL_INFO= MAKEINFO=/usr/tmp/pkgsrc/audio/nas/work/.tools/bin/makeinfo FLEX= BISON= PKG_CONFIG= PKG_CONFIG_LIBDIR=/usr/tmp/pkgsrc/audio/nas/work/.buildlink/lib/pkgconfig:/usr/tmp/pkgsrc/audio/nas/work/.buildlink/share/pkgconfig PKG_CONFIG_LOG=/usr/tmp/pkgsrc/audio/nas/work/.pkg-config.log PKG_CONFIG_PATH= MAKE=make WRAPPER_DEBUG=no WRAPPER_UPDATE_CACHE=yes CC=gcc CFLAGS=-O2\ -I/usr/pkg/include\ -I/usr/include\ -I/usr/X11R7/include CPPFLAGS=-I/usr/pkg/include\ -I/usr/include\ -I/usr/X11R7/include CXX=c++ CXXFLAGS=-O2\ -I/usr/pkg/include\ -I/usr/include\ -I/usr/X11R7/include COMPILER_RPATH_FLAG=-Wl,-R F77=g77 FC=g77 FFLAGS=-O LANG=C LC_ALL=C LC_COLLATE=C LC_CTYPE=C LC_MESSAGES=C LC_MONETARY=C LC_NUMERIC=C LC_TIME=C LDFLAGS=-L/usr/pkg/lib\ -L/usr/lib\ -Wl,-R/usr/lib\ -L/usr/X11R7/lib\ -Wl,-R/usr/X11R7/lib\ -Wl,-R/usr/pkg/lib LINKER_RPATH_FLAG=-R PATH=/usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin:/usr/tmp/pkgsrc/audio/nas/work/.buildlink/bin:/usr/tmp/pkgsrc/audio/nas/work/.gcc/bin:/usr/tmp/pkgsrc/audio/nas/work/.tools/bin:/usr/pkg/bin:/home/ryo_on/bin:/sbin:/bin:/usr/sbin:/opt/bin:/usr/bin:/usr/games:/usr/pkg/sbin:/usr/pkg/bin:/usr/local/bin:/usr/X11R7/bin:/usr/pkg/bin:/usr/X11R7/bin PREFIX=/usr/pkg PKG_SYSCONFDIR=/usr/pkg/etc/nas CXXCPP=cpp HOME=/usr/tmp/pkgsrc/audio/nas/work/.home ./configure checking build system type... x86_64-unknown-netbsd6.99.21 checking host system type... x86_64-unknown-netbsd6.99.21 checking for gcc... gcc checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of executables... checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ANSI C... none needed checking for a sed that does not truncate output... /usr/pkg/bin/gsed checking for egrep... grep -E checking for ld used by gcc... /usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin/ld checking if the linker (/usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin/ld) is GNU ld... yes checking for /usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin/ld option to reload object files... -r checking for BSD-compatible nm... /usr/bin/nm -B checking whether ln -s works... yes checking how to recognise dependent libraries... match_pattern /lib[^/]+(\.so|_pic\.a)$ checking how to run the C preprocessor... gcc -E checking for ANSI C header files... yes checking for sys/types.h... yes checking for sys/stat.h... yes checking for stdlib.h... yes checking for string.h... yes checking for memory.h... yes checking for strings.h... yes checking for inttypes.h... yes checking for stdint.h... yes checking for unistd.h... yes checking dlfcn.h usability... yes checking dlfcn.h presence... yes checking for dlfcn.h... yes checking whether we are using the GNU C++ compiler... no checking whether c++ accepts -g... no checking how to run the C++ preprocessor... cpp checking whether we are using the GNU Fortran 77 compiler... no checking whether g77 accepts -g... no checking the maximum length of command line arguments... 196608 checking command to parse /usr/bin/nm -B output from gcc object... ok checking for objdir... .libs checking for ar... ar checking for ranlib... ranlib checking for strip... strip checking if gcc static flag works... yes checking if gcc supports -fno-rtti -fno-exceptions... no checking for gcc option to produce PIC... -fPIC checking if gcc PIC flag -fPIC works... yes checking if gcc supports -c -o file.o... yes checking whether the gcc linker (/usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin/ld) supports shared libraries... yes checking whether -lc should be explicitly linked in... no checking dynamic linker characteristics... NetBSD ld.elf_so checking how to hardcode library paths into programs... immediate checking whether stripping libraries is possible... yes checking if libtool supports shared libraries... yes checking whether to build shared libraries... yes checking whether to build static libraries... yes configure: creating libtool appending configuration tag "CXX" to libtool checking whether the c++ linker (/usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin/ld) supports shared libraries... PKGSRC-WARNING: Something is trying to run the c++ compiler, PKGSRC-WARNING: but it is not added to USE_LANGUAGES in the package Makefile. yes libtool.m4: error: problem compiling CXX test program checking for c++ option to produce PIC... checking if c++ supports -c -o file.o... no checking whether the c++ linker (/usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin/ld) supports shared libraries... yes checking dynamic linker characteristics... PKGSRC-WARNING: Something is trying to run the c++ compiler, PKGSRC-WARNING: but it is not added to USE_LANGUAGES in the package Makefile. NetBSD ld.elf_so checking how to hardcode library paths into programs... unsupported checking whether stripping libraries is possible... yes appending configuration tag "F77" to libtool checking if libtool supports shared libraries... yes checking whether to build shared libraries... yes checking whether to build static libraries... yes checking for g77 option to produce PIC... -fPIC checking if g77 PIC flag -fPIC works... no checking if g77 supports -c -o file.o... no checking whether the g77 linker (/usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin/ld) supports shared libraries... PKGSRC-WARNING: Something is trying to run the fortran compiler, PKGSRC-WARNING: but it is not added to USE_LANGUAGES in the package Makefile. yes checking dynamic linker characteristics... PKGSRC-WARNING: Something is trying to run the fortran compiler, PKGSRC-WARNING: but it is not added to USE_LANGUAGES in the package Makefile. PKGSRC-WARNING: Something is trying to run the fortran compiler, PKGSRC-WARNING: but it is not added to USE_LANGUAGES in the package Makefile. NetBSD ld.elf_so checking how to hardcode library paths into programs... immediate checking whether stripping libraries is possible... yes checking for bison... bison -y checking for flex... flex checking for yywrap in -lfl... yes checking lex output file root... lex.yy checking whether yytext is a pointer... yes checking for gcc... (cached) gcc checking whether we are using the GNU C compiler... (cached) yes checking whether gcc accepts -g... (cached) yes checking for gcc option to accept ANSI C... (cached) none needed checking for main in -lm... yes checking for crypt in -lcrypt... yes checking for crypt in -lgen... no checking for gzread in -lz... yes checking for ANSI C header files... (cached) yes checking fcntl.h usability... yes checking fcntl.h presence... yes checking for fcntl.h... yes checking limits.h usability... yes checking limits.h presence... yes checking for limits.h... yes checking sys/ioctl.h usability... yes checking sys/ioctl.h presence... yes checking for sys/ioctl.h... yes checking sys/times.h usability... yes checking sys/times.h presence... yes checking for sys/times.h... yes checking termio.h usability... no checking termio.h presence... no checking for termio.h... no checking for unistd.h... (cached) yes checking sys/time.h usability... yes checking sys/time.h presence... yes checking for sys/time.h... yes checking sys/select.h usability... yes checking sys/select.h presence... yes checking for sys/select.h... yes checking stropts.h usability... no checking stropts.h presence... no checking for stropts.h... no checking poll.h usability... yes checking poll.h presence... yes checking for poll.h... yes checking values.h usability... no checking values.h presence... no checking for values.h... no checking time.h usability... yes checking time.h presence... yes checking for time.h... yes checking for string.h... (cached) yes checking for strings.h... (cached) yes checking termios.h usability... yes checking termios.h presence... yes checking for termios.h... yes checking zlib.h usability... yes checking zlib.h presence... yes checking for zlib.h... yes checking for stdint.h... (cached) yes checking for stdlib.h... (cached) yes checking for limits.h... (cached) yes checking malloc.h usability... yes checking malloc.h presence... yes checking for malloc.h... yes checking sys/soundcard.h usability... yes checking sys/soundcard.h presence... yes checking for sys/soundcard.h... yes checking machine/soundcard.h usability... yes checking machine/soundcard.h presence... yes checking for machine/soundcard.h... yes checking for an ANSI C-conforming const... yes checking for size_t... yes checking whether time.h and sys/time.h may both be included... yes checking whether struct tm is in sys/time.h or time.h... time.h checking return type of signal handlers... void checking for vprintf... yes checking for _doprnt... no checking for select... yes checking for strstr... yes checking for fileno... yes checking for setpgrp... yes checking for daemon... yes checking for getmsg... no checking for poll... yes checking for setitimer... yes checking for strerror... yes checking whether setpgrp takes no argument... no checking for snprintf... yes checking for vsnprintf... yes checking for working snprintf... yes checking for working vsnprintf... yes checking for sys_errlist declaration... yes configure: creating ./config.status config.status: creating config.h config.status: config.h is unchanged => Replacing sh interpreter in clients/audio/util/checkmail. set -e; set -u; cd /usr/tmp/pkgsrc/audio/nas/work/nas-1.9.3; for f in clients/audio/util/checkmail; do if [ -f "${f}" ]; then /usr/bin/sed -e '1s|^#![[:space:]]*\(/usr/bin/env[[:space:]][[:space:]]*\)\{0,1\}[^[:space:]]*sh|#!/bin/sh|' < "${f}" > "${f}.new"; if [ -x "${f}" ]; then /bin/chmod a+x "${f}.new"; fi; /bin/mv -f "${f}.new" "${f}"; elif [ -d "$f" ]; then echo >/dev/null '***' "Ignore it, most probably comes from shell globs"; else echo 1>&2 "WARNING:" "[replace-interpreter] Skipping non-existent file \"$f\"."; fi; done => Checking for portability problems in extracted files set -e; [ -d /usr/tmp/pkgsrc/audio/nas/work/nas-1.9.3/. ] || exit 0; cd /usr/tmp/pkgsrc/audio/nas/work/nas-1.9.3; env SKIP_FILTER= sh /usr/pkgsrc/mk/check/check-portability.sh set -e; cd /usr/tmp/pkgsrc/audio/nas/work/nas-1.9.3 && cd /usr/tmp/pkgsrc/audio/nas/work/nas-1.9.3 && /usr/bin/env XPROJECTROOT=/usr/X11R7 CC=gcc CFLAGS=-O2\ -I/usr/pkg/include\ -I/usr/include\ -I/usr/X11R7/include CPPFLAGS=-I/usr/pkg/include\ -I/usr/include\ -I/usr/X11R7/include CXX=c++ CXXFLAGS=-O2\ -I/usr/pkg/include\ -I/usr/include\ -I/usr/X11R7/include COMPILER_RPATH_FLAG=-Wl,-R F77=g77 FC=g77 FFLAGS=-O LANG=C LC_ALL=C LC_COLLATE=C LC_CTYPE=C LC_MESSAGES=C LC_MONETARY=C LC_NUMERIC=C LC_TIME=C LDFLAGS=-L/usr/pkg/lib\ -L/usr/lib\ -Wl,-R/usr/lib\ -L/usr/X11R7/lib\ -Wl,-R/usr/X11R7/lib\ -Wl,-R/usr/pkg/lib LINKER_RPATH_FLAG=-R PATH=/usr/tmp/pkgsrc/audio/nas/work/.wrapper/bin:/usr/tmp/pkgsrc/audio/nas/work/.buildlink/bin:/usr/tmp/pkgsrc/audio/nas/work/.gcc/bin:/usr/tmp/pkgsrc/audio/nas/work/.tools/bin:/usr/pkg/bin:/home/ryo_on/bin:/sbin:/bin:/usr/sbin:/opt/bin:/usr/bin:/usr/games:/usr/pkg/sbin:/usr/pkg/bin:/usr/local/bin:/usr/X11R7/bin:/usr/pkg/bin:/usr/X11R7/bin PREFIX=/usr/pkg PKG_SYSCONFDIR=/usr/pkg/etc/nas CXXCPP=cpp HOME=/usr/tmp/pkgsrc/audio/nas/work/.home _PKGSRCDIR=/usr/pkgsrc CURDIR=/usr/pkgsrc/audio/nas DEPENDS= DISTDIR=/usr/distfiles FILESDIR=/usr/pkgsrc/audio/nas/files LOCALBASE=/usr/pkg PATCHDIR=/usr/pkgsrc/audio/nas/patches PKGSRCDIR=/usr/pkgsrc SCRIPTDIR= VIEWBASE=/usr/pkg WRKDIR=/usr/tmp/pkgsrc/audio/nas/work WRKSRC=/usr/tmp/pkgsrc/audio/nas/work/nas-1.9.3 X11BASE=/usr/X11R7 BSD_INSTALL_PROGRAM=/usr/bin/install\ -c\ -s\ -o\ ryo_on\ -g\ users\ -m\ 755 BSD_INSTALL_SCRIPT=/usr/bin/install\ -c\ -o\ ryo_on\ -g\ users\ -m\ 755 BSD_INSTALL_LIB=/usr/bin/install\ -c\ -o\ ryo_on\ -g\ users\ -m\ 755 BSD_INSTALL_DATA=/usr/bin/install\ -c\ -o\ ryo_on\ -g\ users\ -m\ 644 BSD_INSTALL_MAN=/usr/bin/install\ -c\ -o\ ryo_on\ -g\ users\ -m\ 644 BSD_INSTALL=/usr/bin/install BSD_INSTALL_PROGRAM_DIR=/usr/bin/install\ -d\ -o\ ryo_on\ -g\ users\ -m\ 755 BSD_INSTALL_SCRIPT_DIR=/usr/bin/install\ -d\ -o\ ryo_on\ -g\ users\ -m\ 755 BSD_INSTALL_LIB_DIR=/usr/bin/install\ -d\ -o\ ryo_on\ -g\ users\ -m\ 755 BSD_INSTALL_DATA_DIR=/usr/bin/install\ -d\ -o\ ryo_on\ -g\ users\ -m\ 755 BSD_INSTALL_MAN_DIR=/usr/bin/install\ -d\ -o\ ryo_on\ -g\ users\ -m\ 755 BSD_INSTALL_GAME=/usr/bin/install\ -c\ -s\ -o\ ryo_on\ -g\ users\ -m\ 2555 BSD_INSTALL_GAME_DATA=/usr/bin/install\ -c\ -o\ ryo_on\ -g\ users\ -m\ 664 BSD_INSTALL_GAME_DIR=/usr/bin/install\ -d\ -o\ ryo_on\ -g\ users\ -m\ 775 WRAPPER_DEBUG="no" /usr/pkg/bin/xmkmf -a mv -f Makefile Makefile.bak imake -DUseInstalled -I/usr/pkg/lib/X11/config make Makefiles make[1]: Entering directory `/usr/tmp/pkgsrc/audio/nas/work/nas-1.9.3' making Makefiles in include... mv -f Makefile Makefile.bak usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] making Makefiles in server... mv -f Makefile Makefile.bak usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] making Makefiles in lib... mv -f Makefile Makefile.bak usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] making Makefiles in clients... mv -f Makefile Makefile.bak usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] making Makefiles in doc... mv -f Makefile Makefile.bak usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] making Makefiles in config... mv -f Makefile Makefile.bak usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] make[1]: Leaving directory `/usr/tmp/pkgsrc/audio/nas/work/nas-1.9.3' make includes make[1]: Entering directory `/usr/tmp/pkgsrc/audio/nas/work/nas-1.9.3' including in ./include... usage: make [-BeikNnqrstWX] [-C directory] [-D variable] [-d flags] [-f makefile] [-I directory] [-J private] [-j max_jobs] [-m directory] [-T file] [-V variable] [variable=value] [target ...] make[1]: *** [includes] Error 2 make[1]: Leaving directory `/usr/tmp/pkgsrc/audio/nas/work/nas-1.9.3' *** Error code 2 Stop. make: stopped in /usr/pkgsrc/audio/nas set -e; /bin/rm -f /usr/tmp/pkgsrc/audio/nas/work/.warning/*.tmp; test -d /usr/tmp/pkgsrc/audio/nas/work/.warning || exit 0; cd /usr/tmp/pkgsrc/audio/nas/work/.warning; for file in ./*; do test "$file" != "./*" || exit 0; break; done; /bin/cat ./* | /usr/bin/sed -e "s|^|WARNING: |" 1>&2; /bin/mv -f ./* /usr/tmp/pkgsrc/audio/nas/work/.warning-done WARNING: *** Please consider adding c++ to USE_LANGUAGES in the package Makefile. WARNING: *** Please consider adding fortran to USE_LANGUAGES in the package Makefile. set -e; /bin/rm -f /usr/tmp/pkgsrc/audio/nas/work/.error/*.tmp; test -d /usr/tmp/pkgsrc/audio/nas/work/.error || exit 0; cd /usr/tmp/pkgsrc/audio/nas/work/.error; for file in ./*; do test "$file" != "./*" || exit 0; break; done; /bin/cat * | /usr/bin/sed -e "s|^|ERROR: |" 1>&2; if /usr/bin/awk 'END { exit (NR > 0) ? 0 : 1; }' ./*; then /bin/mv -f ./* /usr/tmp/pkgsrc/audio/nas/work/.error-done; exit 1; fi *** Error code 1 Stop. make: stopped in /usr/pkgsrc/audio/nas