Part VI. Building the system

Table of Contents

32. Obtaining the sources
32.1. Preparing directories
32.2. Terminology
32.3. Downloading tarballs
32.3.1. Downloading sources for a NetBSD release
32.3.2. Downloading sources for a NetBSD stable branch
32.3.3. Downloading sources for a NetBSD-current development branch
32.4. Fetching by CVS
32.4.1. Fetching a NetBSD release
32.4.2. Fetching a NetBSD stable branch
32.4.3. Fetching the NetBSD-current development branch
32.4.4. Saving some cvs(1) options
33. Crosscompiling NetBSD with build.sh
33.1. Building the toolchain
33.2. Configuring the kernel manually
33.3. Building the kernel manually
33.4. Building the kernel with build.sh
33.5. Building the userland
33.6. Building the X Window System
33.7. Changing build behaviour
33.7.1. Changing the Destination Directory
33.7.2. Static Builds
33.7.3. Using build.sh options
33.7.4. make(1) variables used during build
34. Compiling the kernel
34.1. Requirements and procedure
34.2. Installing the kernel sources
34.3. Creating the kernel configuration file
34.4. Building the kernel manually
34.4.1. Configuring the kernel manually
34.4.2. Generating dependencies and recompiling manually
34.5. Building the kernel using build.sh
34.6. Installing the new kernel
34.7. If something went wrong
35. Updating an existing system from sources
35.1. Manual build and update procedure
35.1.1. Building a new userland
35.1.2. Building a new kernel
35.1.3. Installing the kernel and userland
35.1.4. Updating the system configuration files
35.1.5. Summary
35.2. Using sysinst
35.3. Using sysbuild and sysupgrade
35.3.1. Tweak: Building as non-root
35.3.2. Tweak: Setting up nightly builds
35.4. More details about the updating of configuration and startup files
35.4.1. Using etcupdate with source files
35.4.2. Using etcupdate with binary distribution sets
35.4.3. Using etcmanage instead of etcupdate
36. Building NetBSD installation media
36.1. Creating standard installation images with build.sh
36.2. Creating custom live disk images